10:231 $ H403 358_•I|¥‰ÓMjqØ‚¦ ë<óo¬ÄÃf 403 Forbidden

Forbidden

You don't have permission to access this resource.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

 � 355¾ÄÃc 404 Not Found

Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

! ˆl–äY>”TÔD¨ ÅõÆEp-©‹FÿÇ 0ÆÅÄ ˆÂÇ „e·ÝgÆÅÄ?÷a ´i�­ã@sdZddlZddlZddlZddlZddlZddlZgd¢Zgd¢Zgd¢Z gd¢Z gd¢Z gd¢Z gd ¢Z d Zd Zgd ¢Zd ZiZdd„ZdZdZdd„Zeefdd„Zeefdd„Zdd„ZGdd„deƒZGdd„deƒZGdd„deƒZGd d!„d!eeƒZGd"d#„d#eeƒZdd$lm Z e d%d&ƒZ!e d'd(ƒZ"e d)d*ƒZ#d+e!_d,e!j$_d-e!j%_d.e"_d/e"j&_d0e"j'_d1e"j(_d2e"j)_d3e"j%_d4e#_e"j&je#j&_e"j'je#j'_e"j(je#j(_d5e#j*_e"j)je#j)_e"j%je#j%_eZ+Gd6d%„d%e!eƒZ,Gd7d'„d'e"eƒZ-Gd8d)„d)e#eƒZ.Gd9d:„d:e!eƒZ/Gd;d<„d„d>e#eƒZ1d?d@„Z2e2ƒ[2d¤dCdD„Z3dEdF„Z4d¥dGdH„Z5dIdJ„Z6dKdL„Z7dMdN„Z8d¦dOdP„Z9dQdR„Z:dSdT„Z;d§dUdV„Zda?dZd[„Z@e Ad\¡ZBd¨d_d`„ZCd©dcdd„ZDdªdedf„ZEd«dgdh„ZFeGdiƒZHeIeHƒZJiZKGdjdk„dkejLƒZMd¬dmdn„ZNd­dodp„ZOd®dqdr„ZPdadAddeOfdsdt„ZQdudv„ZRdwdx„ZSdydz„ZTd{d|„ZUdaVd}d~„ZWdd€„ZXdaYd�d‚„ZZdƒd„„Z[d…d†„Z\d‡dˆ„Z]d‰dŠ„Z^d‹dŒ„Z_da`d�dŽ„Zad¯d�d‘„Zbd°d’d“„Zcd”d•„Zdd–d—„Zed˜d™„Zfdšd›„Zgdœd�„ZhdždŸ„Zid d¡„Zjd¢d£„ZkdS)±a3Parse (absolute and relative) URLs. urlparse module is based upon the following RFC specifications. RFC 3986 (STD66): "Uniform Resource Identifiers" by T. Berners-Lee, R. Fielding and L. Masinter, January 2005. RFC 2732 : "Format for Literal IPv6 Addresses in URL's by R.Hinden, B.Carpenter and L.Masinter, December 1999. RFC 2396: "Uniform Resource Identifiers (URI)": Generic Syntax by T. Berners-Lee, R. Fielding, and L. Masinter, August 1998. RFC 2368: "The mailto URL scheme", by P.Hoffman , L Masinter, J. Zawinski, July 1998. RFC 1808: "Relative Uniform Resource Locators", by R. Fielding, UC Irvine, June 1995. RFC 1738: "Uniform Resource Locators (URL)" by T. Berners-Lee, L. Masinter, M. McCahill, December 1994 RFC 3986 is considered the current standard and any future changes to urlparse module should conform with it. The urlparse module is currently not entirely compliant with this RFC due to defacto scenarios for parsing, and for backward compatibility purposes, some parsing quirks from older RFCs are retained. The testcases in test_urlparse.py provides a good indicator of parsing behavior. The WHATWG URL Parser spec should also be considered. We are not compliant with it either due to existing user code API behavior expectations (Hyrum's Law). It serves as a useful guide when making changes. éN)ÚurlparseÚ urlunparseÚurljoinÚ urldefragÚurlsplitÚ urlunsplitÚ urlencodeÚparse_qsÚ parse_qslÚquoteÚ quote_plusÚquote_from_bytesÚunquoteÚ unquote_plusÚunquote_to_bytesÚ DefragResultÚ ParseResultÚ SplitResultÚDefragResultBytesÚParseResultBytesÚSplitResultBytes)ÚÚftpÚhttpÚgopherÚnntpÚimapÚwaisÚfileÚhttpsÚshttpÚmmsÚprosperoÚrtspÚrtspuÚsftpÚsvnúsvn+sshÚwsÚwss)rrrrrÚtelnetrrrr!rr Úsnewsr"r#r$Úrsyncr&r'r%ÚnfsÚgitzgit+sshr(r))rrÚhdlr"rrrr r#r$ÚsipÚsipsr!r%Útel) rr/ÚmailtoÚnewsr*rrr+r0r1) rrrrrr r!rr#r$r0r1) rrr/rrr4rrrr r+rr"