Normal $ˆl–äY>” je¶…8 Cq§nµ1hß „e·žoÁÀ¿?÷a ´i]±ã@sZdZddlZddlZddlZddlZddlZddlZddlZddl Z ddl Z ddl Z ddl Z ddl mZgd¢ZdZdZdZdZd Zd Ze d ej¡ZGd d „d eƒZGdd„deƒZGdd„deƒZGdd„deƒZGdd„deƒZGdd„deƒZ Gdd„deƒZ!Gdd„deƒZ"Gdd„deƒZ#Gdd„deƒZ$d d!„Z%d"d#„Z&d$d%„Z'd&d'„Z(d(d)„Z)z ddl*Z*Wne+�y‚d*Z,Yn0d+Z,Gd,d-„d-ƒZ-e,�r¶Gd.d/„d/e-ƒZ.e /d/¡d0Z0Gd1d2„d2e-ƒZ1e2d3k�rVd4d5„Z3e3d6ƒZ4e3d7ƒ 5d8¡Z6e7d9ƒd:Z8e j9 :¡Z;e;�s�qe8e;Z8�qþe7d;ed=¡e= ?e4e6e8¡e= @¡dS)>aSMTP/ESMTP client class. This should follow RFC 821 (SMTP), RFC 1869 (ESMTP), RFC 2554 (SMTP Authentication) and RFC 2487 (Secure SMTP over TLS). Notes: Please remember, when doing ESMTP, that the names of the SMTP service extensions are NOT the same thing as the option keywords for the RCPT and MAIL commands! Example: >>> import smtplib >>> s=smtplib.SMTP("localhost") >>> print(s.help()) This is Sendmail version 8.8.4 Topics: HELO EHLO MAIL RCPT DATA RSET NOOP QUIT HELP VRFY EXPN VERB ETRN DSN For more info use "HELP ". To report bugs in the implementation send email to sendmail-bugs@sendmail.org. For local information send email to Postmaster at your site. End of HELP info >>> s.putcmd("vrfy","someone@here") >>> s.getreply() (250, "Somebody OverHere ") >>> s.quit() éN)Ú body_encode) Ú SMTPExceptionÚSMTPNotSupportedErrorÚSMTPServerDisconnectedÚSMTPResponseExceptionÚSMTPSenderRefusedÚSMTPRecipientsRefusedÚ SMTPDataErrorÚSMTPConnectErrorÚ SMTPHeloErrorÚSMTPAuthenticationErrorÚ quoteaddrÚ quotedataÚSMTPéiÑú s i éz auth=(.*)c@seZdZdZdS)rz4Base class for all exceptions raised by this module.N©Ú__name__Ú __module__Ú __qualname__Ú__doc__©rrú/usr/lib64/python3.9/smtplib.pyrHsrc@seZdZdZdS)rzÌThe command or option is not supported by the SMTP server. This exception is raised when an attempt is made to run a command or a command with an option which is not supported by the server. NrrrrrrKsrc@seZdZdZdS)rzÌNot connected to any SMTP server. This exception is raised when the server unexpectedly disconnects, or when an attempt is made to use the SMTP instance before connecting it to a server. NrrrrrrRsrc@seZdZdZdd„ZdS)ra2Base class for all exceptions that include an SMTP error code. These exceptions are generated in some instances when the SMTP server returns an error code. The error code is stored in the `smtp_code' attribute of the error, and the `smtp_error' attribute is set to the error message. cCs||_||_||f|_dS©N)Ú smtp_codeÚ smtp_errorÚargs)ÚselfÚcodeÚmsgrrrÚ__init__cszSMTPResponseException.__init__N©rrrrr!rrrrrZsrc@seZdZdZdd„ZdS)rz«Sender address refused. In addition to the attributes set by on all SMTPResponseException exceptions, this sets `sender' to the string that the SMTP refused. cCs"||_||_||_|||f|_dSr)rrÚsenderr)rrr r#rrrr!oszSMTPSenderRefused.__init__Nr"rrrrrhsrc@seZdZdZdd„ZdS)rzÎAll recipient addresses refused. The errors for each recipient are accessible through the attribute 'recipients', which is a dictionary of exactly the same sort as SMTP.sendmail() returns. c